1. avatar doctorlilt
    Bit of a techy problem this...

    I have an ESI MAYA44USB soundcard for my laptop and it's always worked fine.
    I've used the ASIO drivers that came with it to playback and record audio on my laptop and it's been great.

    I also had ASIO4ALL drivers and I still use them the odd time, when my external MAYA soundcard is packed away (I'm move about a fair bit with my laptop and gear).

    Point is, the above has had no problems untill recently when I decided to upgrade the laptop.
    I added a new 250GB Hard drive and another 512MB RAM.

    The best way I saw to install this new stuff, was to just stick the RAM in (easily done) then use some free software off the net to CLONE my old hard drive onto the new one.

    So I used XXCLONE, simple program. Free (for home use). Seemed to do the trick, no problem.
    After a few hours, the data from the old hard drive was all onto the new one. I was able to put the new one into the laptop and boot up into XP.

    When XP fully booted, everything looked exactly as it had on the old drive. All the same programs, files, layout etc. So as far as I can see, it all went perfect.


    As soon as I go to use audio... it's GLITCH CITY.

    I can't record or playback in any of my software without glitching all over the place. And playing stuff online stremed content (youtube / myspace etc ) is also glitching.

    I tried reinstalling the ESI MAYA 44 drivers, but it's made no difference. I've tinkered with the ASIO4ALL settings. Still no joy.

    Does anyone have any suggestions? Am I better to just format the new hard drive and start from scratch instead of trying this CLONE business?

    Are there any bits of software or Windows secret hiding places for getting audio to run properly?

  2. avatar DontPetABurningDog

    Perhaps reinstalling Motherboard drivers would be the way forward.

    Also, check the RAM timings.

    That being said, I'd favour reformatting anyway as a matter of course. XP systems seem to need it every 12-18 months.
  3. avatar Tele
    Try to listen to the audio on another system. I don't really think the RAM timings would cause this problem, if anything they SPD timings are more conservative than what the RAM may be capable of. Either way, I doubt it'd cause these weird errors. It wouldn't hurt to take out the new stick just to be on the safe side.

    Of course, make sure the audio files themselves are not the problem first. Try uninstalling the sound card drivers, check the manufacturer's site for the newest set and install them.

    If that doesn't work, my advice would be to use that old drive by getting a 2.5" caddy, backing up the audio onto it and doing a fresh install of XP, then transfer it back and try again.

    Sounds like a driver issue though considering it's affecting all audio.
  4. avatar Recycled Alien
    I would guess that all is not well with the disk, and therefore Windows is working like a bastard to keep the system running. So everything else that is time-critical is suffering.

    You still have the old disk, right? So anything you do will not lose vital music, data, etc.

    Use the XP tools to test and check your hard disk.

    Re-format and re-install if you must. Then copy your vital data via USB or something. I bought a 3.5" ATA, 2.5" ATA and SATA to USB interface off eBay recently. Cost a fiver.
  5. avatar doctorlilt
    Yea, got the old disk in a wee 2.5 usb caddy, so all won't be lost if I don't get to the bottom of this.

    Just starting afresh with XP, by formatting this new drive, then moving over the essential old hard drive files... Well it's more than likely going to solve the issue, as I reckon it's most likely a problem with data that perhaps wasn't cloned properly.

    But it's going to be a fucking pain in the balls. Having to reinstall all my software again. Transfer the old files. Finding the right ones etc... A whole day job.

    That's a last resort really.

    I've also got a random error in Super Collider (a music program we use in college) saying something about not being able to close a Registry file, which to me, confirms some sort of mishap with the Cloning of the old drive. Plus, I am just naturally suspicious of FREEWARE I guess.

    I've just used Defrag and Disk Clean Up... I'm gonna restart and see if that's made any difference...
  6. avatar doctorlilt
    ...Nah. That's made FUCK ALL difference.

    So to confirm:

    I've run a registry cleaner program which cleaned up lost / invalid registry keys.

    Reinstalled Soundcard software and drivers (both that came with the sound card and ASIO4ALL 3rd party drivers).

    Run scan disk, disk clean up and Defragged the C drive.


    Hmmm... Suppose I'll try taking out the extra RAM.
  7. avatar DontPetABurningDog
    A reformat is a pain in the hole, yes, but it's one of those things that's for the best in the long run.

    Check the power options in Windows, too. Make sure they're set to Home/Office Desk, and that Speedstep/Intel powersaving is off in the BIOS. Occasionally, powersaving features downclock your CPU and everything starts to act the bollocks, particularly anything processor intensive. In theory, the Processor steps up again to meet demand, but we don't live in Theory. My machine acted the pure bollocks on account of this, pulling a BSOD anytime something more intensive than Minesweeper was running, so it's worth a shot.

    Another thing to try would be booting on the Old HD again, Run->Regedit, pick "File", "Export Registry", and save your original reg. to disk as a Reg. file. Then, reboot on the New drive, and import the old reg file from the old disk. Theoretically, this will ensure your new reg. is identical to the working old one.
  8. avatar doctorlilt
    Know about keeping the power saving options off, I also tried taking the RAM out etc. No joy.

    Oddly, last night my internet just died. Not sure if it's related, because it's been working fine on this (upgraded) laptop for a few days, but it's never crashed like that before.

    The old registry export idea sounds pretty good though. I'll give that a wee go.
  9. avatar Sadoldgit
    I must admit, I would fresh install xp and reinstall your drivers.

    Cloning a drive, you are getting all the registry errors, frgmnetation problems and other crap associated with windoze .
    Bite the bullet and reinstall.

    If reinstalling your audio drivers doesnt work, I think you need to seriously consider it.
  10. avatar tenrabbits
    I'm with rec alien on this one - it sounds to me like your new disk isn't working up to speed. Is it the same rpm as the old drive? It might be you've just got a faulty HDD.
  11. avatar doctorlilt
    Hmmm, yea, I think I'm going to have to consider a fresh install. ARSE.

    I noticed the glitching with online audio stuff wasn't quite so bad when the external soundcard was disconnected, but it was still there, a wee bit.


    The HDD is the same speed as the old one, but everything else is running fine on it, scan disk found no errors and other programs are running fine.


    I think come January, I'm gonna bite the bullet and buy myself a fucking Mac.
  12. avatar Recycled Alien
    [quote:11de91f2bb="doctorlilt"]I think come January, I'm gonna bite the bullet and buy myself a fucking Mac.[/quote:11de91f2bb]Hmmm. There have been more pleas for help with Mac than Windows on fastfude in the last year.
  13. avatar feline1
    that's bizarre because Macs always "just work" don't they? :lol:
  14. avatar fastfude
    I wonder what the ratio of ff-users-producing-music-on-a-PC vs ff-users-producing-music-on-a-mac is?

    Windows certainly holds sway amongst the total readership this month:

    Windows - 79.5%
    OS X - 18%
    iPhone - 1.5%
    Linux - 0.5%
    Misc Others - 0.5%
  15. avatar Pete
    Just a quick thought, make sure the hard drive is running in UDMA mode and not PIO. The stuttering audio description matches a problem my housemate had with his laptop a while back and I tracked it down to that.

    Check it in the properties panel of the Primary IDE controller in Device manager. If it is set to PIO you can force it to reset to UDMA by telling device manager to disable the primary IDE channel, then reboot and when windows loads it will reinstall the drivers for the controller and set itself up for UDMA5.
  16. avatar doctorlilt
    hmm Pete, that sounded like a promising solution, however, I ended up fucking up the Registry. Trying to transfer the old one over and replace it on top of the new drive, which was ok untill I got cocky and used "Eusing Registry Cleaner" to get rid of, what I thought would be, now redundant registry keys. Instead, I fucked the drive up so it would no longer boot. D'oh!

    So basically, I started from scratch again. Over the last couple of nights I've been reinstalling all my old programs from scratch onto a freshly formatted drive.

    So far so good...